Quantcast

canceling autovacuum task error

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

canceling autovacuum task error

tamanna madaan-2
Hi All
 
I am using a cluster setup having postgres-8.4.0 and slon 2.0.4 is being used for replication . It happened that the autovacuum was not running successfully on one of the nodes in cluster and was giving error :
 
2011-05-13 23:07:42 CDTERROR:  canceling autovacuum task
2011-05-13 23:07:42 CDTCONTEXT:  automatic vacuum of table "abc.abc.sometablename"
2011-05-13 23:07:42 CDTERROR:  could not open relation with OID 141231 at character 87
 
sometimes it was giving a different error as below :
 
2011-05-13 04:45:05 CDTERROR:  canceling autovacuum task
2011-05-13 04:45:05 CDTCONTEXT:  automatic analyze of table "abc.abc.sometablename"
2011-05-13 04:45:05 CDTLOG:  could not receive data from client: Connection reset by peer
2011-05-13 04:45:05 CDTLOG:  unexpected EOF on client connection
2011-05-13 04:45:05 CDTERROR:  duplicate key value violates unique constraint "sl_nodelock-pkey"
2011-05-13 04:45:05 CDTSTATEMENT:  select "_schemaname".cleanupNodelock(); insert into "_mswcluster".sl_nodelock values (    2, 0, "pg_catalog".pg_backend_pid());
 
Can see the below log also in postgres logs :
 
"checkpoints are occurring too frequently (19 seconds apart)"
 I am not sure when these all errors started coming . Just noticed these when database size grew huge and it became slow.
 
Can anybody shed some light on it if these errors are related or what could be the reason for these errors .
 
Thanks..
Tamanna


 
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: canceling autovacuum task error

Scott Marlowe-2
On Tue, Aug 9, 2011 at 11:07 PM, tamanna madaan
<[hidden email]> wrote:
> Hi All
>
> I am using a cluster setup having postgres-8.4.0 and slon 2.0.4 is being

There are known data eating bugs in that version of postgresql, and I
personally had issues with earlier 2.0.x releases.  There are
important updates to BOTH of those packages you need to install.

> Can anybody shed some light on it if these errors are related or what could
> be the reason for these errors .

You are running a known buggy version of postgresql.  Update to the
latest 8.4.x immediately.  Your database may be corrupted beyond easy
recovery, got a backup?

--
Sent via pgsql-general mailing list ([hidden email])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-general

Loading...